Set Object Property Value

Mar 1, 2012 at 10:10 PM

I read this post and I am basically having the same issue as the user. http://opalisadextension.codeplex.com/discussions/262455

I am using Get Object DistinguishedName & Set Object Property Value.  Get Object works fine and gets the correct LDAP path.  Then I get this message on the Set Object Property Value object.

The specified directory service attribute or value does not exist.

Exception: DirectoryServicesCOMException
Target site: DirectoryEntry.CommitChanges

Stack trace:
   at System.DirectoryServices.DirectoryEntry.CommitChanges()
   at Active_Directory.setObjectPropertyValue.<setPropertyValue>d__0.MoveNext()
   at Opalis.QuickIntegrationKit.Framework.Core.FilterSet.Filter(IEnumerable values)
   at Opalis.QuickIntegrationKit.Framework.Core.FilteredResponse.PublishRange(IEnumerable values)
   at Active_Directory.setObjectPropertyValue.Execute(IOpalisRequest request, IOpalisResponse response)

Property Name is description and Property value is TEST.  I used Get Object Property Values and get a whole list and chose description from that list.  I have verified that I have version 1.8 installed.


 

 

Mar 2, 2012 at 3:43 PM

I took another shot at this today and got it working.  When I set up the workflow, created the first Set Object Property Value object then copied it about 10 times, 1 for each value I wanted to set in AD.  It appears that there's some issue with the copied objects.  I was able to recreate the workflow using new Set Object Property Value objects each time and they all work fine.  Not sure if this is a bug with the IP or something within Opalis.